Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Ruby Build a Todo List Application with Rails 4 Build a Todo List Application with Rails 4 Generate a Scaffold

janeporter
PLUS
janeporter
Courses Plus Student 23,471 Points

Action Controller error: ExecJS::ProgramError in TodoLists#index error...

I'm trying to pull up the todo_lists on localhost:3000 (rails server) and get the following error:

Showing C:/Users/jporter/Documents/ruby_projects_tth/odot/app/views/layouts/application.html.erb where line #5 raised:

TypeError: Object doesn't support this property or method Rails.root: C:/Users/jporter/Documents/ruby_projects_tth/odot

Application Trace | Framework Trace | Full Trace app/views/layouts/application.html.erb:5:in `app_views_layouts_application_html_erb_130890288_65002540' Request

Parameters:

None Toggle session dump Toggle env dump

fyi: I have rails 4.2...

Caleb Schmidt
seal-mask
.a{fill-rule:evenodd;}techdegree seal-36
Caleb Schmidt
Front End Web Development Techdegree Graduate 18,686 Points

I can't get mine to work either. I have tried all the solutions that the other people have listed in the older posts. Nothing works. Any help would be appreciated.

1 Answer

Anybody solve this problem?

I had the same problem

Showing C:/Users/wd/Desktop/myapp/app/views/layouts/application.html.erb where line #5 raised:

TypeError: El objeto no acepta esta propiedad o método Rails.root: C:/Users/wd/Desktop/myapp

Application Trace | Framework Trace | Full Trace app/views/layouts/application.html.erb:5:in `app_views_layouts_application_html_erb_400840886_80761032'

A friend of mine told me that it could be because of windows..he told me use Ubuntu instead