Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

HTML HTML Basics Going Further with HTML Linking to Sections of a Web Page

Kris Smith
Kris Smith
2,992 Points

Articles not linking to section. Here is the code: <li><a href="#articles">Articles</a></li>

Every other section linked perfectly. I removed the code, re-added it, and still nothing.

Camilo Lucero
Camilo Lucero
27,692 Points

Can you add the complete HTML?

Emmanuel C
Emmanuel C
10,635 Points

Did you add the id of articles to the appropriate section element tag? Posting the whole source code would help more, also check out the Markdown Cheatsheet for tips on how to format it, to make it easier to read.

2 Answers

Hi Kristen,

your code looks correct.

Therefore I assume that the problem is within the "id" attribute that the link goes to...

Could you copy the complete code in here? Or maybe you find the problem already if you take a look at the id attribute...

If you copy the code make sure to include "´´´html" at the beginning of the code and "´´´" at the end so the code will be transformed into nicely readable code format here. :-)

Happy coding and always keep going!

Nils

You want to make sure that your section has the proper attribute id, that both of them are plural or singular, and they have matching uppercase/lowercase letters. Hopefully that helps.

So it should look like:

<section id="articles">