Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

iOS Build a Simple iPhone App with Swift Views and View Controllers Introduction to Views

Button does not show

I have tried adding a button but when I run the program the button does not show, just the label and "copy right reserved" at the bottom of the simulator.

It used to display the button until I tried the next step to add functionality to the button, an NSUnknownKeyException error appeared, so I deleted the button and went back to add the button again. And the button does not show anymore now!

Can someone help me with this issue please?