Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

HTML HTML Forms Inputs

Adel Hameed
Adel Hameed
3,427 Points

Checkboxes and radio are still showing as input fields

Checkboxes and radio are still showing as input fields. The password is still showing the characters. I've tried it in both Chrome and Safari. What am I doing wrong?

The following is the code: <!doctype html> <html lang="en"> <head> <meta charset="utf-8"> <title>My Page</title> </head> <body> <form action="#" method="POST" name="my_form"> <input type=“text” name=“username"> <br> <input type=“password” name=“password"><br> <input type=“radio” name=“gender" value="Male">Male<br> <input type=“radio” name=“gender" value="Female">Female<br> <input type=“checkbox” name=“foods" value="Grapes">Grapes<br> <input type=“checkbox” name=“foods" value="Apples">Apples<br> <input type=“checkbox” name=“foods" value="Oranges">Oranges<br> </form>

</body> </html>

James Barnett
James Barnett
39,199 Points

The forum uses markdown to correctly format code, check out this thread on how to type code in the forum for some examples.

Adel Hameed
Adel Hameed
3,427 Points

Thank you for the help.

Regards,

Adel

1 Answer

Dennis Skoko
Dennis Skoko
12,860 Points

It seems your code didn't make it trough. You can use Codepen to give us your code and I also suggest you use HTML Validator to see what the problem is. My guess is that you made a typo and didn't close a tag that messes up the other ones.

Hope that helps! Regards, Dennis.

Adel Hameed
Adel Hameed
3,427 Points

Thank you for the help. It worked, I copied and pasted the exact code from Codepen to the file in Sublime and it worked.

Regards, Adel