Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community!

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial


Could not install ImageMagick on mac OSX El Capitan

When ever I try to install ImageMagick with homebrew it keeps showing the same error: Error: You must brew link xz libtool before imagemagick can be installed

When ever I run: brew link xz libtool
it says: Linking /usr/local/Cellar/xz/5.2.2... Error: Could not symlink . /usr/local/opt is not writable.

1 Answer

Vlad Filiucov
Vlad Filiucov
10,665 Points

try gem install image_magic

It does not work for me it keeps saying: ERROR: While executing gem ... (Errno::EPERM) Operation not permitted - /usr/bin/bulk_shrink

This happens even with sudo.