Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial


Eclipse says phone is offline, nothing works

I have a relatively new Galaxy S4 and Eclipse doesn't recognize it. The device chooser says it's offline. This is a list of everything I have tried in troubleshooting for the last hour or so:

  • Downloaded the most recent driver from the Samsung website
  • Downloaded Samsung Kies
  • Restarted the phone
  • Restarted Eclipse
  • Different USB ports
  • Different USB cords
  • Debugged (turning it on and off and on again)
  • Reset ADB (which gives me this lovely error in the console "[2013-09-23 20:33:50 - DeviceMonitor]Adb connection Error:An existing connection was forcibly closed by the remote host")

Is there anyway I can fix this or am I doomed to never test the Crystal Ball app on my actual phone? Help.

2 Answers

Dan Giles
Dan Giles
2,243 Points

Sounds a lot like a driver issue. You may have already tried this, but if not try using the Google drivers. You can go to your device manager (I'm assuming you are using Windows and the Eclipse ADT bundle), finding your Android device and do a driver update, browse to a manual location, and point it at your sdk\extras\google\usb_driver directory. I was having a similar problem until I started using that driver

Note I also had problems where Eclipse kept dropping the connection; I often had to power down the phone, unplug it from the computer, turn it on again and then plug it in and it would recognize the USB connection and Eclipse could see it.

Still didn't work. Either I did it wrong or it just doesn't like me. Oh well. Thanks for the advice

Ben Jakuben
Ben Jakuben
Treehouse Teacher

Hi Melody,

There is a popular question on StackOverflow about using the S4 with Eclipse on Windows. Can you see if this solution helps? http://stackoverflow.com/a/16256100/475217

I had already turned debugging in developer mode on and it made no difference. Still offline. Thanks anyway though!