Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community!

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

HTML HTML Objects Embedded Elements

Embedded Elements

Though I embed the YouTube video as instructed, it flashes briefly in the browser, then disappears. Why?

3 Answers

<!doctype html>
<html lang="en">

</head>
    <meta charset="utf-8">
    <title>Anchors</title>
<head>

<BODY>

    <object width="420" height="315">
        <param name="movie" value="http://www.youtube.com/v/_OBlgSz8sSM?hl=en_US&amp;version=3"></param>
        <param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param>
        <embed src="//www.youtube.com/v/_OBlgSz8sSM?hl=en_US&amp;version=3" type="application/x-shockwave-flash" width="420" height="315" allowscriptaccess="always" allowfullscreen="true"></embed>
    </object>

</BODY>

</html>
Colton Fitzgerald
Colton Fitzgerald
15,815 Points

In the embed tag, add "http:" in front of the youtube link :)

Andrew Dushane
Andrew Dushane
9,264 Points

You're using the old embed code. Is there a reason you're not using the newer iframe embed?

I'm following the procedure shown on the video. The newer iframe embed hasn't been introduced yet. Maybe I need to move on to another video.