Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Ruby

Getting following error An error occurred while installing json (1.8.1), and Bundler cannot continue

I am trying to create a new rails app test. But I am getting following error while running bundle install.

An error occurred while installing json (1.8.1), and Bundler cannot continue.

I tried various options like xcode-select --install, rm -rf test as given in previously asked question but no success.

Please help me in resolving this issue. I am stuck because of this error.

2 Answers

Have you tried running with sudo?

Yes I tried and it is resolved now. Thanks for your help.