Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Business

Nicholas Dixon
Nicholas Dixon
9,514 Points

Google Analytic's not working properly

I set-up Google Analytic's on 3 Websites, mine, one for a friend and one for an Art Society. all have statistics that list some of the landing pages for the sites as Websites outside my Websites, such as porn site forums and other forums. I have no idea what is going on, they are sites I don't go on. I don't understand what is going on.

Allen Williamson
Allen Williamson
18,327 Points

I think we have a similar problem. From what I understand some spammers are using the Google ID number and not really hitting your site. I used to get 120 hits per day, at only 1 - 2 second average stay. Not 100% why they are doing this, other than trying to drive traffic. Some of the ones showing up in my analytics linked to Amazon (which is a violation of the TOS) Russian forums, and random Italian commerce sites. Just getting traffic I guess.

Here are some links concerning similar situations. Ultimately it appears to be more a nuisance than anything harmful at this stage. If we are indeed on the same page. Good luck.

https://productforums.google.com/forum/#!topic/analytics/q62Z9dNe524%5B1-25%5D http://www.analyticsedge.com/2014/12/removing-referral-spam-google-analytics/ http://www.jeffalytics.com/8-steps-eliminating-bad-data-google-analytics/

Nicholas Dixon
Nicholas Dixon
9,514 Points

Thanks Allen, after reading the articles I have set-up a Valid Hostname Filter, I hope I have done it right, and I will find out in a couple of days if the data from GA is good.