Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Ruby

Josh Flowers
Josh Flowers
7,010 Points

How to Install Gems on OSX Mavericks

Ok, so Ruby 2.0 comes stock on OSX Mavericks but I'm stuck on how to install gems / libraries. I'm doing the ruby foundations deep dive and not sure what i need to install as the instructions are for older versions of Ruby and the osx gcc installer doesn't have any link for Mavericks.

Are you getting errors when you run 'gem install'? If so, can you let them here? If not, what specific trouble are you having?

1 Answer

Josh Flowers
Josh Flowers
7,010 Points

I figured out the problem, thanks anyway