Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community!

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial


John Rothra
John Rothra
6,711 Points

How to Remove Widgets From WooCommerce Individual Product Post

This is starting to bug me because I can't figure out the answer. I'll try to keep it brief but thorough.

I recently installed the WooCommerce plugin on my site and I'm in the process of customizing. For things related to the store, I want no WordPress (WP) sidebar widgets displayed, but I do want them to remain on regular blog posts.

This was easy to do for most of WooCommerce because it created specific WP pages. However, when it comes to how it shows individual products, it treats that as a WP post. In my theme I'm able to say not to display the WP widget sidebar on posts, but this affects all posts, both the WooCommerce individual products and regular blog posts. That's not what I want.

I tried looking for a post related to WooCommerce products, but there are no posts for individual products listed in the Posts section of the dashboard for me to customize. It seems to be a custom post type, but not really.

How do I accomplish this? I'm baffled and Google's not helping. I'm sure I'm overlooking something obvious.

Storefront: www.johnrothra.com/store (no widget sidebar)

Individual product: http://www.johnrothra.com/product/1x-evangelism-kingdom-growth-strategy-local-church/ (widget sidebar, but I want it gone)

1 Answer

John Rothra
John Rothra
6,711 Points

Okay, I feel really, really silly now. After a really busy week I had a chance to sit down and re-examine the problem. I realized that when entering the individual product, I didn't have "Layout Options" checked on the WP screen options. I checked that, changed the layout to no sidebar, and voila, problem solved.

Note: don't try to problem solve when frustrated, else you'll overlook the obvious.