Development Tools Installing a Ruby Development Environment Installing a Ruby Development Environment Installing Ruby on Mac

i am getting these error everytime i try to install gem bundler and gem rails

gem install bundler ERROR: Could not find a valid gem 'bundler' (>= 0), here is why: Unable to download data from https://rubygems.org/ - Errno::ECONNRESET: Connection reset by peer - connect(2) (https://rubygems.org/quick/Marshal.4.8/bundler-1.9.8.gemspec.rz)

any one knows what is the problem

3 Answers

now i fixed my internet it start saying this error Fetching: i18n-0.7.0.gem (100%) ERROR: While executing gem ... (Gem::FilePermissionError) You don't have write permissions for the /Library/Ruby/Gems/2.0.0 directory.

Hi Ali, l suppose your internet is slow. try later.

I have this error too, and I don't think it's because of my internet speed