Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial


I get an error while trying to run a program in Android Studio.

Hello. I just finished watching the first few videos in the Android track and am trying to set the emulator up. I start the virtual android phone up and its running but when I try to run the program, it wont send it to the virtual phone. Instead I get the following:

Waiting for device. Target device: Android442 [emulator-5554] Uploading file local path: C:\Users\Andrew\AndroidStudioProjects\FunFacts\app\build\outputs\apk\app-debug.apk remote path: /data/local/tmp/Arktikh.funfacts Installing Arktikh.funfacts DEVICE SHELL COMMAND: pm install -r "/data/local/tmp/Arktikh.funfacts" pkg: /data/local/tmp/Arktikh.funfacts


I was wondering if anyone had an idea? I have tried re installing and even tried deleting project files and starting over.

Thanks! Andrew

1 Answer

There could be a number of possible reasons.

Did you check this link here Stack Overflow

Maybe this helps