Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Ruby Installing Rails on Mac

Daniel Valderrama
Daniel Valderrama
1,818 Points

Im unable to install rails (v 5.0.0)

When I input the command 'gem install rails --version 5.0.0' I get the following error in the terminal:

ERROR: Loading command: install (LoadError) dlopen(/Users/DanielValderrama/.rbenv/versions/2.2.1/lib/ruby/2.2.0/x86_64-darwin15/openssl.bundle, 9): Library not loaded: /usr/local/opt/openssl/lib/libssl.1.0.0.dylib Referenced from: /Users/DanielValderrama/.rbenv/versions/2.2.1/lib/ruby/2.2.0/x86_64-darwin15/openssl.bundle Reason: image not found - /Users/DanielValderrama/.rbenv/versions/2.2.1/lib/ruby/2.2.0/x86_64-darwin15/openssl.bundle ERROR: While executing gem ... (NoMethodError) undefined method `invoke_with_build_args' for nil:NilClass

Any ideas? Thanks in advance.

2 Answers

Daniel Valderrama
Daniel Valderrama
1,818 Points

Oh, I actually resolved it by updating ruby and RVM to their latest versions. It worked after that.

Maciej Czuchnowski
Maciej Czuchnowski
36,440 Points

Daniel,

if you're using MacOS, please try the second answer in this StackOverflow issue: http://stackoverflow.com/questions/19168842/library-not-loaded-opt-local-lib-libssl-1-0-0-dylib-loaderror

namely - remove and install openssl