Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

iOS

IOS Ribbit program works fine but is really slow

Hi.

I have finished the Ribbit program and it seems to work as expected but just seems to run really slowly when getting the pictures from Parse. It works fine and normal speed when its logging in and logging out but its when its loading the test images etc. Is that possible because I am running it in the simulator only or is there another possible reason??

Any help would be appreciated.

Cheers

3 Answers

not much you can do about that you're at the whim of your network and parse's availability.

OK thanks. It just seemed to fly on the video and mine is working at a snail's pace so wasn't sure if there was something I had done wrong.

If it's working in general you are probably ok. There are are a lot of factors, your image size, your computer (if you are using the simulator), your network proximity to parse vs their proximity to parse. I know it runs slow on mine because I'm using a 5 year old MBP. I wouldn't sweat speed issues unless you are doing it on a phone and even then there's not much you can do.

yeah the MBP I have is fairly new but will try it with a smaller image to see how that works. Maybe the image I am using was too big