Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

PHP Build a Simple PHP Application Integrating with PayPal Array Keys

ISBN showing but still i am shown read strip.why?

I have done the task IMO correctly, but it gives a error. http://awesomescreenshot.com/0d02lwlr76 , am i missing something?

Stone Preston
Stone Preston
42,016 Points

can you post the code your are using, just because the output looks correct doesnt necessarily mean the code is what the challenge engine is looking for.

yea sure, here is the code

<?php

$books["978-0743261690"] = "Gilgamesh";
$books["978-0060931957"] = "The Odyssey";
$books["978-0192840509"] = "Aesop's Fables";
$books["978-0520227040"] = "Mahabharta";
$books["978-0393320978"] = "Beowulf";

?><html>
<head>
    <title>Five Great Books</title>
</head>
<body>
    <h1>Five Great Books</h1>
    <ul>
        <?php foreach($books as $isbn => $book) { ?>
            <li><?php echo $book ."&nbsp;" ."(" .$isbn .")" ?></li>
        <?php } ?>
    </ul>
</body>
</html>

It spits out 2 errors, one that code is fine but format isn't correct, and the other i mentioned above.

2 Answers

Stone Preston
Stone Preston
42,016 Points

You really dont need to use a no blank space here. just put a space in the quotes and it works. Although it renders fine in the browser, the challenge engine must not be accepting it for some reason. Use

<li><?php echo $book ." " ."(" .$isbn .")" ?></li>

instead.

It worked! Phew!, i thought i was doing it wrong, i am not that bad after all. :D