Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

Java Java Objects (Retired) Creating the MVP Getting Started

Java Workspace Issue

When I try to launch the workspace for Hangman.java it tells me that I am not authorized and will not load anything. I've tried closing the browser and deleting the cookies but nothing has worked so far. All the other workspaces work just fine except for this one.

Derek McCool
Derek McCool
12,289 Points

Happening to me as well.

Thank you all for the quick responses! I'm not sure what the issue was but it seems it has resolved itself and I am no longer receiving that error. If the problem ever arises again I will try these suggestions. Thanks again!

3 Answers

Adnan Pozegić
Adnan Pozegić
12,789 Points

If Grigorijs solution didn't work, try this:

  1. go to workspaces ( from the left sidebar menu - last option )
  2. create a blank workspace - make sure you can run it
  3. download project files
  4. upload project files to that workspace and use it for the project
Grigorij Schleifer
Grigorij Schleifer
10,365 Points

Hi Martin,

try to relaunch the workspace. Some peaple here in the forum reported that going to the next video and relaunching the browser solved the problem.

Report back if it wasn´t helpful


Hreiðar Ingi Hallgrímsson
Hreiðar Ingi Hallgrímsson
Courses Plus Student 2,856 Points

I am not in the same course but, what worked for me was to fork the workspace from the workspace overview and it opened.