Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

JavaScript JavaScript Loops, Arrays and Objects Tracking Multiple Items with Arrays Adding Data to Arrays

Lots of 404 errors. Cant find helpers.js Treehouse bug?

https://w.trhou.se/drjad4b6lq

I don't think the problem is with my code, I have been having this problem rather consistatnly with the "JavaScript Loops, Arrays and Objects" course. The task with the colored circles I ran my code locally instead and it worked fine. This task gives me the error:

http://port-80-4bvnm9qtrj.treehouse-app.com/js/playlist.js Failed to load resource: the server responded with a status of 404 (Not Found)

If I copy and paste the function into the beginning of the playlist.js file, everything works fine. So it is accessing the playlist.js file that I created but not the included helpers.js. Is this a treehouse bug?

3 Answers

Thank you.

Although I definitely did. Not sure why the snapshot didn't have that in the index. I just updated my post with a new snapshot. Although I am specifying the sub folders, I am still getting the 404's. This has been giving me problems for the last several videos.

There is something REALLY weird going on here, when I go back into my workspace, not the snapshot, the helpsers.js file is inside the js directory. The playlist.js file is not and even though the helpers.js file is in the js, directory and the proper path is in the index.html, I still get a 404 error for the helpers.js. I downloaded the zip of project files and have been working locally with no issues. I moved the playlist.js into the js folder and all seems to be working.