Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Android

Joseph Mejorada
Joseph Mejorada
2,939 Points

My device is not being detected (Shaking Things Up, Running an App on a Device)

My device does not appear in Eclipse when I plug my phone (Samsung Galaxy S III) to my computer with a USB. I have installed the drivers for this device, tried installing Samsung Kies (other forums say that I have to do this with an S3), and I even updated the firmware for my device. I have reset my computer and Eclipse still can't detect my device. Any idea on how to solve this issue?

2 Answers

If you have a password, pin, or unlock pattern set on your phone, you may need to unlock it before it will communicate with your computer.

Scott Kipfer
Scott Kipfer
10,348 Points

Do you have USB debugging enabled on your phone, in the developer options? Also I had to mount my phone as a camera to get mine to connect.