Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

CSS How to Make a Website Customizing Colors and Fonts Use Classes in CSS

Andrea Montini
Andrea Montini
2,202 Points

My nav a.selected class selector doesn't affect the preview of the site. HTML and CSS perfectly match.

In the preview it simply doesn't work, and I cannot see the "selected" state as soon as I open the page. Something might be wrong with the browser?

Can you post you code, a second pair of eyes might see something you don't. Look at the markdown cheat sheet below the comment box if you don't know how to do that.

You can also post a snapshot of your workspace.

https://teamtreehouse.com/forum/workspace-snapshots

4 Answers

Andrea Montini
Andrea Montini
2,202 Points

Hey thanks for your answers but I cannot find out how to attach my shots.

The link I gave shows you how to put a snapshot link in your post.

Andrea Montini
Andrea Montini
2,202 Points

Oh great! Thanks. I've missed it before. So here it is: https://w.trhou.se/p5puc25kf7! Not sure wether this snapshot show all files or only the file i was working on (html).

Are you sure you took a snapshot of your current workspace? This one doesn't contain any files.

Andrea Montini
Andrea Montini
2,202 Points

I tried to make another snapshot but it doesn't come up with files. I don't what it's going wrong, but I've also noticed that when I try to click "Launch Workspaces" Safari does not open it in a new tab but instead it opens a new windows like a "pop-up". Neither by clicking on "Open link in a new tab" works and instead open up a window without normal navigation bar in the browser.

What's wrong?

Were you able to get workspaces working again?

Andrea Montini
Andrea Montini
2,202 Points

Thank you guys, now it seems working again. I haven't done anything just yet, but now the markup and the CSS seems matching and the "selected" state correctly display in the preview of the website! Thank you tho.