Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Java Java Objects Meet Objects Creating Classes

Chandlerj Jones
Chandlerj Jones
18,378 Points

Picked up JAVA_TOOL_OPTIONS: -Xmx128m Picked up _JAVA_OPTIONS: -Xmx128m

The following code appears in console everytime I run java code.

Picked up JAVA_TOOL_OPTIONS: -Xmx128m
Picked up _JAVA_OPTIONS: -Xmx128m

2 Answers

Alexander Nikiforov
seal-mask
.a{fill-rule:evenodd;}techdegree seal-36
Alexander Nikiforov
Java Web Development Techdegree Graduate 22,161 Points

Read Teacher's notes more often :)

In Java Basics course first video Teachers Notes

you can find the following line:

Not to worry, the Picked up JAVA_TOOL_OPTIONS: -Xmx128m is not an error on your part, we recently just tweaked our setup to have more memory allocated. Don't fret that mine looks different!

Najib Nazar
Najib Nazar
869 Points

Is there any way to suppress that? It popping up is the not the problem but its making the console look very messy. Please and thank you.

Alexander Nikiforov
seal-mask
.a{fill-rule:evenodd;}techdegree seal-36
Alexander Nikiforov
Java Web Development Techdegree Graduate 22,161 Points

Not really.

Read here for some workarounds.

But judging from answers you'll spend more efforts hiding this message, then simply ignoring it :)

Switch to IDE, get faster to 'Local Development Environments' course. and message will disappear.

James Chengberlin
James Chengberlin
837 Points

I found a way to hide the message. Copy this line in the console:

unset JAVA_TOOL_OPTIONS && unset _JAVA_OPTIONS

It worked for me and my brother.

Alexander Nikiforov
seal-mask
.a{fill-rule:evenodd;}techdegree seal-36
Alexander Nikiforov
Java Web Development Techdegree Graduate 22,161 Points

By unsetting these Options you will also make your Java compiler less faster.

Do you really want to do that?

The point of these changes was for Treehouse Java Virtual Machine to work faster.

If you unset these options you make it slower again.

So be aware that you are not hiding the message, but rather the turning off the options that verbosely show you when they are on