Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

iOS iOS Tools CocoaPods CocoaPods

Problem installing CocoaPods

I've opened the terminal and tried installing CocoaPods:

$ sudo gem install cocoapods

but get the following error:

-bash: $: command not found

3 Answers

Yup, solved my problems. Many thanks Patrick.

Patrick Donahue
Patrick Donahue
9,523 Points

Go into Xcode and install Command Line Tools. Xcode - dropdown Xcode open developer tools More developer tools

From there install command line tools. This should help!

Installed it, thanks!

Where do I find the command line tools after rebooting Xcode? I thought it would be under the same menu as you mentioned above. Or maybe I was supposed to install in a custom location rather than default?

edit: supposed to be a comment

Patrick Donahue
Patrick Donahue
9,523 Points

The command line tools just update your terminal. So once you download it - try the cocoapods again.