Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Android

Problem running Genymotion: 'Unable to load VirtualBox engine' error encountered

Hi guys,

I downloaded the Genymotion installer for Windows. I installed both Genymotion and Oracle VirtualBox via the installer. I received messages that both programs were successfully installed. I successfully opened VirtualBox, then tried opening Genymotion, only to encounter an error message saying 'Unable to load VirtualBox engine'. I have tried reopening Genymotion and encountered the same message.

If it helps, I am currently using a Lenovo Yoga running Windows 8.1 One other important thing to note is that quite some time back I tried using VirtualBox to start a Windows Phone emulator and similarly failed. Is there anyway to fix the Genymotion error I encountered? If so, how?

Also, if somehow my laptop just refuses to run Genymotion, is learning how to make Android apps using an actual phone as your only way to test apps a feasible way of learning? I say this because I only downloaded Genymotion in the first place because my Android Studio emulator was running incredibly slow and ran into 'System process isn't responding' errors all over the place.

Sorry for the long post, and thanks a bunch in advance for the help.

Cheers, John

Chandler Tayek
Chandler Tayek
5,513 Points

Hi John. Sorry this is a late response but if your still curious about the issue do you mind posting the full log error in a comment?