Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Android

Problem with Android Emulator

Hi everybody,

i am stuck at the first android exercise, the "Hello World" exercise where you have to write "The answer is YES". I follow all the steps that Ben shows but when i try to run the app the Android emulator doesn't load the app. It only emulates the cellphone/android environment.

Can someone help?

2 Answers

Ben Jakuben
STAFF
Ben Jakuben
Treehouse Teacher

Sorry you're having trouble! When you launch the app, Eclipse will give you some messages in the pane at the bottom, either in the LogCat tab or the Console tab. Can you copy/paste your Console messages in here? If it only says "DDMS" in the upper left, you'll need to switch to the Android console by clicking on the little computer monitor icon on the right of the pane: Eclipse console

Thanks for the quick reply Ben.

Well this is what appears in the Android console:

[2013-10-26 10:31:27 - Crystal Ball] ------------------------------
[2013-10-26 10:31:27 - Crystal Ball] Android Launch!
[2013-10-26 10:31:27 - Crystal Ball] adb is running normally.
[2013-10-26 10:31:27 - Crystal Ball] Performing com.example.crystal.ball.MainActivity activity launch
[2013-10-26 10:31:27 - Crystal Ball] Automatic Target Mode: launching new emulator with compatible AVD 'Android4.1'
[2013-10-26 10:31:27 - Crystal Ball] Launching a new emulator with Virtual Device 'Android4.1'
[2013-10-26 10:31:37 - Emulator] emulator: warning: opening audio input failed
[2013-10-26 10:31:37 - Emulator]

Funny thing! I have been trying to get the first exercise to display on the emulator with no success but i tried the next exercise ("Enlighten me!" button on the Initial Layout video) and it shows on the emulator.

I just hope this doesn't come back further down the road.

Ben Jakuben
Ben Jakuben
Treehouse Teacher

How strange! It seems like it might be related to the error about "opening audio input failed". But I'm glad it's working!