Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

WordPress WordPress Basics Managing Content in WordPress Pages in WordPress

Problem with the url

Url of my pages and post is always localhost/wordpress/index.php/page or post slug....

Why index.php always appear as it should not be appear with the url?

Is there any way to fix it?

Thanx in advance

3 Answers

Dale Severude
seal-mask
.a{fill-rule:evenodd;}techdegree seal-36
Dale Severude
Full Stack JavaScript Techdegree Graduate 71,324 Points

Hi Nishant, While in the Admin area, go to Settings, then Permalinks, check Post Name and then Save Changes. You should be able to change the URL for your site at this location.

Thanks for helping Dale..

But it is not working without "index.php" in the URL, if I choose 'Post name' as Permalink then it display "Page Not Found" error..

Only Plain Permalink works for me and also custom with mentioning "index.php"..

What is that Problem? Please Help Me