Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

General Discussion

Problems with teamtreehouse.com's landing page and login with "private browsing"

I thought I'd let you guys know that when turning on "private browsing" in latest Safari (6.0.5), the landing page of teamtreehouse.com redirects to teamtreehouse.com/login (that is, it claims I cannot even see "pricing and plans", for example, without login, which is clearly funny...). This actually happens even when I am already logged in. Anyways, after this redirect, there are problems login problems: when I enter my username and password, I get the 404 ("did not expect that" with mike the frog) and there is still a button to login in the navbar (even though, i am already logged in, as can be seen when clicking the "forum" in the tool bar).

2 Answers

Nick Pettit
STAFF
Nick Pettit
Treehouse Teacher

Hi George Ant,

That's really strange. Thanks for letting us know! Would you mind sending an email to help@teamtreehouse.com about this? They might have additional questions for you that will help our developers debug the issue. :)

Steve Berrill
Steve Berrill
19,591 Points

I seem to be always receiving errors when trying to access the website. Naturally I always go to the homepage to login but when i enter my credentials, the server is unresponsive and I receive a 504 error. see screenshot http://i.imgur.com/UtNCVsF.png

I like to login mainly on windows 7 with Google Chrome then sometimes on my Xbox360 with IE and Google Chrome on my Sony Google TV box. I try logging in from 3 different locations on lots of different devices and different browsers and all I get is 504 error (timeout)

But searching upon this problem on Google I came across this thread which then lets me access this page and i can see that I am already logged in. Also I have noticed that browsing the Library is very slow, I cannot click to go home and most track / Library pages receive 504 errors also.

Also when I try to play videos from the Library on IE on the XBOX360 the sound is way out of sync to the video so there are issues with the video player here.

I am paying for this service so its very frustrating for me.

Nick Pettit
Nick Pettit
Treehouse Teacher

Hi Steve,

Sorry for the slow reply. In the future, please email help@teamtreehouse.com when you're having issues using the site. Our full time support staff would be happy to assist you. I've notified them so they can figure out what's up! They should be in contact soon.

Nick Pettit
Nick Pettit
Treehouse Teacher

Hi Steve,

Just spoke to our support staff and it sounds like they already communicated to you over email. :)