Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

iOS

simulator not showing results

hi i have got to the part you click the button and i am trying to run the project in simulator but all i get is a black screen , Xcode says no issues but its saying attaching to crystal ball

3 Answers

Alex Hedley
Alex Hedley
16,381 Points

If you press the home button does the icon for the app show in the simulator?

yes it dose

Alex Hedley
Alex Hedley
16,381 Points

It can sometimes take a while to load the first time as it is compiling all the resources. Try a clean build and see if that helps.

just tried a clean build (blank) and still getting a black screen plz help

Same here, struggling to figure this out. Were you able to resolve?

Maher Alhasan
Maher Alhasan
974 Points

Go to the General settings in your project by clicking on the .xcodeproj in the Navigator pane on the left-hand side. Make sure "Main Interface" section under "Deployment Info" has your main storyboard selected. If that doesn't work, upload your project to dropbox or something similar so I can sift through it.