Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

JavaScript Node.js Basics 2017 Building a Command Line Application Making a GET Request with https

*[SOLVED]* -- https.get not being accepted

I'm trying to do the challenge to use the https.get request. I've tested this code in the node.js console and it works fine ... but the challenge screen doesn't like it. I can't see the error because this window doesn't move. ... something 'unexpected ...'

const https = require('https'); https.get(https://teamtreehouse.com/chalkers.json, (res) => { console.log('statusCode:', res.statusCode); } );

app.js
const https = require('https');
https.get(`https://teamtreehouse.com/chalkers.json`, (res) =>
          {  console.log('statusCode:', res.statusCode); }
         );




//https.get(`https://teamtreehouse.com/chalkers.json`, response => { console.dir(response);  });

Moderator Edited: Marked as Post as solved.

solved the problem ... it was the quotes around the URL