Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial


Status update Ruby Error

I am currently doing "Generate a Rails Application". After doing the "rake db:migrate" command and starting the server brings me to an error page, rather than what is shown in the video.


ExecJS::RuntimeError in Statuses#index

4 Answers

Found solution in forum:

Download and install nodejs from http://nodejs.org/download/.

Add the following to the Gemfile:

gem "execjs"

Then run "bundle install" and try it again.

Strange you needed execjs . . . we're you adding something off-course? Because my application doesn't require it. (just curious)

No I tried to follow the tutorials as is yet still got the weird error. Noticed other users have gotten a similar issue though.

Martin S
Martin S
1,724 Points


I had the same error, for me, the solution ended up being installing node.js then re-installing rails, hope that helps, cheers