Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

General Discussion

vy le oai
vy le oai
4,697 Points

sublime text 2 not auto choose language to build

I have set up SASS Builder and Jade Builder in Sublime Text 2. But everytime I want to build one of two types of file, I have to change the Buld system via menu Tools -> Build system -> language. Although I have selected Automatic selection, Sublime just doesn't change build system automatically as I would like. Any suggestion? Thank you very much!

2 Answers

Hi there,

I click the language in the bottom right gutter and select from there. Also, at the top of that list, you can set the language for each file extension. That might help you out


Codin - Codesmite
Codin - Codesmite
8,600 Points

I do the same as Steve, I click the button in the bottom right gutter and change to what I require, there is an option at the top of the menu "Open all with current extension as" where you can set the default for the extension of the file you are viewing :)