Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

PHP Build a Basic PHP Website (2018) Listing and Sorting Inventory Items Associative Arrays

The code editor area in the code challenges seems to be having problems. I have tried it in Firefox, Chrome, and Edge.

The code editor area will not give me a cursor unless I go to the bottom of the page and then come up line by line until I get to the required line. I can only see one or two lines of the code in the code challenge at a time. I can only get to the third question of the challenge when I get a "Connection Broken" message. These problems have stopped me from proceeding. Is this something that you are aware of?

6 Answers

Hi Kevin,

Try disabling your plugins to see if that helps. You should be able to do this temporarily by opening a new window up in Incognito Mode (Chrome) or Private window (Firefox). If it works within one of those two disabled plugin windows then the likely problem is a plugin on your browser that you'll need to remove/disable.

You can also try clearing any cache and Treehouse related cookies and reboot your system. Hope that helps!

I disabled my plugins, cleared my cache and rebooted. I am still having the same problem

Nathan Ward
Nathan Ward
7,895 Points

I have had this problem recently too hopefully they will fix this issue soon.

I tried this on another network and had the same results.

Hi Kevin,

Sorry none of that seemed to fix the issue. Can you email us at, help@teamtreehouse.com and provide screenshots of what you are experiencing along with the error message? This will allow us to attempt to replicate the issue.

I am no longer having this problem. It seems to have been resolved.