Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Development Tools

The | Pipe Key in the console doesn't work

Hello!

I use a Belgian AZERTY keyboard, and for some reason I can not get the pipe key | to be typed down in the console.

The tilde character works when I do AltGr + = and then press the spacebar, but none of the other AltGr characters work, including the pipe key.

Ctrl + alt + | doesn't work either.

I haven't managed to copy the pipe key in the console either, as ctrl+v didn't work.

I've tried other combinations including various keys, then I added some witchcraft and devilworshipping, but none of it seemed to work.

Is there a solution to this, or is this another sabotage attempt by Lullaby!?

Thanks,

J-B

Agh, it seems that when I change the keyboard mapping to international, I manage to enter it.

It's kind of a hassle though, having to change to the international keyboard layout, but it's a solution, if not the perfect one!

1 Answer

Thanks for the quick reply!

But unfortunately, it doesn't work, this is the combination I usually use as well, but any combination including the AltGr key is ignored, apart from the tilde after I press the spacebar.

I believe this is a problem many of us "foreigners" are having. I just recently had this problem with the tilde-character. I can type it just fine, but some of the inputs in the lessons will not recognize it as a character. For it to work I also have to change my keyboard layout to International.

Hopefully this is something they will fix very soon.