Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Android Build a Simple Android App (2014) Getting Started with Android Setting Up an Android Development Environment for Windows

The program can't start some how because MSVCP90.dll is missing. It said to reinstall this program. What program?

I updated when it said there was a update in Android Studio.

Thanks Gloria

David Santos - You are welcome :)

5 Answers

Have you tried to delete it and unzip the file again? If not try to do unzip it again, and run the program before making a shortcut for the .exe file. If you still get the error after that let us know.

Android Studio needs a DLL that's provided by other apps written in Visual C++. To get the DLL you need to install Microsoft Visual C++ 2010 Redistributable Package (x86)

http://www.microsoft.com/en-us/download/details.aspx?id=5555

If you have a 64bit Windows version, select the x64 addon package when you download.

I seem to be having this problem too. I am extracting and copying the files, and it is going very slowly. Seems like it should be done sometime tomorrow. I'm getting a little discouraged getting started here.

Got it! Another great help Gloria

I am glad it is working now. Initially things can be frustrating but try to keep it up, it is certainly worth it to know a new skill.

Alex Andres
Alex Andres
1,797 Points

I had the same problem as well. I downloaded the file and then extract and created a shortcut and tried to run it, but it gave me this stupid error. So then i deleted the folder android-studio-bundle and re-downloaded many times until i notice there was to 2 android-studio-bundle downloaded one was extracted and the other not so i ran the extracted one. I also ran the program before creating the shortcut like Gloria said. IDK weird stuff. Maybe it was trying to run the one that was not extracted.

Yes Alex, there are 2 android studio executable in the zip. One is for 64 bit computers and another one for 32 bit. So you have to run the appropriate one. It's nice that it works now.