Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

WordPress WordPress Theme Development Starting a WordPress Theme Setting Up A WordPress Theme Folder

Treehouse-portfolio theme not showing up? Please Help !

Hi guys I am learning how to make my own wordpress themes. I am following the video but my theme is not showing up on my local wordpress. How do I get it to show up there ?

11 Answers

Zac Gordon
STAFF
Zac Gordon
Treehouse Guest Teacher

You mentioned your theme folder is in the htdocs root folder. Is it inside of the "wp-content/themes/" folder?

Hi Peaches,

Please explain what exactly you have done so far, So we can take a look and help :)

Ok I already have Mamp installed and running. I've also already installed wp locally .

Under preferences in MAMP my Web Server is set to my htdocs folder that is in my

MAMP application. I am in my local wp (localhost), I created treehouse-portfolio folder in

the htdocs under the themes folder. I have created , styles.css, index.php and

functions.php. I saved them, according to the video after they,ve been saved the new

theme should show up under preferences/themes. Mine does not show up. I am sure that

I am missing something small but, I do not know what it is yet.

Have you added the necessary meta information into your css file? can you paste your current code here please?

/* Theme Name: Treehouse Portfolio Theme Author: Treehouse Author URI: http://teamtreehouse.com/ Description: A post modern, simple, responsive portfolio theme designed in WordPress Theme Development course at Treehouse. Version: 1.0 License: GNU General Public License v2 or later License URI: http://www.gnu.org/licenses/gpl-2.0.html Tags: black, white, light, one-column, two-columns, left-sidebar, flexible-width, fluid-layout, responsive-layout, custom-menu, featured-images

At Treehouse we believe that you should reach for your dreams. You are welcome to use this theme privately or commercially you want to help accomplish those dreams! */

This is the meta data that I have in styles.css

Your meta information are fine

/* 
Theme Name: Treehouse Portfolio Theme 
Author: Treehouse 
Author URI: http://teamtreehouse.com/ 
Description: A post modern, simple, responsive portfolio theme designed in WordPress Theme Development course at Treehouse. 
Version: 1.0 License: GNU General Public License v2 or later 
License URI: http://www.gnu.org/licenses/gpl-2.0.html 
Tags: black, white, light, one-column, two-columns, left-sidebar, flexible-width, fluid-layout, responsive-layout, custom-menu, featured-images

At Treehouse we believe that you should reach for your dreams. You are welcome to use this theme privately or commercially you want to help accomplish those dreams! 
*/

Are you sure that you have the proper permission on treehouse-portfolio and everything inside?

I believe so. I have no problem starting from scratch. When you say proper

permissions do you mean for the user ? Because my user has all permissions.

Or what steps do you suggest I take ?

In your terminal, go to your theme path and type this command

ls -l

it will show every directory/file and it's owner & permissions

result would be something like that

http://i971.photobucket.com/albums/ae191/Ma7asino/Screenshotfrom2014-11-04013735.png

Please post yours :)

What I have noticed is that my wp install is differnt from Zac's own in the way that it does not ask me about my database. It skips that part entirely.

It is not allowing me to access it. I am going to start this section over and let you know what happens. In the first video that showed you haw to set the path the path was different

In this video we're using the htdocs path I did switch to it but maybe something went wrong in the switching. I will try this approach and let you know. I will once again try to access the path from terminal.

No it wasn't I will correct that now. I was also researching the setup process as setting up a local database didn't show up. I found that I needed to edit my wp-config.php folder to include the database information which I just did. I'm about to try everything again I will update this as soon as I am done.

Okay I built the theme in the proper folder and I did make the changes to the wp-config.php folder. I followed the instructions from the video. The theme is now showing up under Broken Themes. Says that the stylesheet is missing:

Broken Themes

The following themes are installed but incomplete. Themes must have a stylesheet and a template.

Name Description treehouse-portfolio Stylesheet is missing.

But I do have the style.css saved with the metadata that i've listed above.

Okay I got the theme to show up. I deleted the style.css file that I had, remade it, added some random text to my index.php file. Saved all refreshed the page and now it's there. :D thanks guys !

Zac Gordon
STAFF
Zac Gordon
Treehouse Guest Teacher

Yes, you may need an index.php as well as a style.css file.

Gina Russo
Gina Russo
8,742 Points

Mine wasn't showing up either...silly mistake....I was editing the project download files instead of my localwp.com folder. All is well!

Inas Hyatt
Inas Hyatt
4,454 Points

Hey! I was having the exact same issue! I saved the file and in filezilla i manually transferred it into my public html. Will this give my problems down the road?