Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial


Rory Costello
Rory Costello
4,109 Points

Trouble installing the Treehouse VM on Windows for Rails

I'm falling at the last hurdle and I don't know why. I've installed everything but when I go to cmder and get to the part where I need to type 'vagrant up' it's returning different text than what is shown in the video. Then when I type 'vagrant ssh' I'm getting spat out in C:\Users\MyName\treehouse instead of the 'welcome to the treehouse vm' message.

Any thoughts? I tried uninstalling and reinstalling everything but no joy.

Aisha Blake
Aisha Blake
Treehouse Guest Teacher

What text are you seeing when you type "vagrant up"? I was having trouble with this earlier and I just had to let it download the box. It just took a reaaaaaaaally long time. Unfortunately, I'm now having an issue where nothing happens when I type "vagrant ssh"...

1 Answer

Having the same issue as you. I run vagrant up and it seems to run without any problems. Then I enter vagrant ssh and it says I need to first run vagrant up. ????

Hello, Treehouse. Are you out there? We need you!