Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community!

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

Ruby Ruby on Rails 5 Basics Creating an App Creating a Rails App

Justin Reed
Justin Reed
Full Stack JavaScript Techdegree Student 33,916 Points

Trouble with bin/rails server

When I run the command I get this back. Tried installing ExecJS but that didnt do anything.

Thanks for the help

/Library/Ruby/Gems/2.6.0/gems/execjs-2.7.0/lib/execjs/runtimes.rb:58:in `autodetect': Could not find a JavaScript runtime. See https://github.com/rails/execjs for a list of available runtimes. (ExecJS::RuntimeUnavailable) Justins-MacBook-Air-4:blog justinreed$

1 Answer

Try installing node.js on your macbook, that looks like it could be the issue