Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

JavaScript npm Basics (retiring) Installing Packages with npm Installing Local Packages

Deepak Rohan Sekar
Deepak Rohan Sekar
9,634 Points

Unable to install bcrypt on Mac

I am getting the below error

$npm install bcrypt

> bcrypt@1.0.2 install /Users/rohan/node_modules/bcrypt
> node-pre-gyp install --fallback-to-build

node-pre-gyp ERR! Tried to download(404): https://github.com/kelektiv/node.bcrypt.js/releases/download/v1.0.2/bcrypt_lib-v1.0.2-node-v48-darwin-x64.tar.gz node-pre-gyp ERR! Pre-built binaries not found for bcrypt@1.0.2 and node@6.10.0 (node-v48 ABI) (falling back to source compile with node-gyp) CXX(target) Release/obj.target/bcrypt_lib/src/blowfish.o CXX(target) Release/obj.target/bcrypt_lib/src/bcrypt.o CXX(target) Release/obj.target/bcrypt_lib/src/bcrypt_node.o SOLINK_MODULE(target) Release/bcrypt_lib.node clang: warning: libstdc++ is deprecated; move to libc++ with a minimum deployment target of OS X 10.9 [-Wdeprecated] COPY /Users/rohan/node_modules/bcrypt/lib/binding/bcrypt_lib.node TOUCH Release/obj.target/action_after_build.stamp /Users/rohan └── bcrypt@1.0.2

npm WARN enoent ENOENT: no such file or directory, open '/Users/rohan/package.json' npm WARN rohan No description npm WARN rohan No repository field. npm WARN rohan No README data npm WARN rohan No license field.