Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

Databases Mongo Basics Go Further With Mongo Updating Data

Unable to run mongo shell after installing Mongo-Hacker?

I install mongo hacker using npm and now getting the error ".mongorc.js file in your home folder could not be executed" when I try to run the shell?

Damien Watson
Damien Watson
27,419 Points

I just added mongo hacker through npm thinking I might get the same error but it worked fine.

Looking through some posts, one comment said to check the version of Mongo, needs to be at least 2.2 to work. Check : https://github.com/TylerBrock/mongo-hacker/issues/1

2 Answers

I saw that too but I have Mongo 3.0 which I think should work since Its more recent than the recommended 2.2 not older.

Damien Watson
Damien Watson
27,419 Points

Yeh, mine is 3.2 but it shouldn't be a problem for 3.0. If I could replicate the error I could help.

The '.mongorc.js' file is quite long as well. Maybe something with the installation? You could try removing and reinstalling or worse case just remove if you want to continue with the MongoDB course. I did it without Mongo-Hacker which is why I only just installed it now.

I have this problem too.