Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

General Discussion

Jeremy Germenis
Jeremy Germenis
29,854 Points

Videos are no longer auto playing

None of the videos are auto playing any more. The video loading animation will disappear and the pause button is present in the video controls. If I click pause then play it will play or even jump to a different time in the video.

I am using: firefox v28 + mac os x 10.6

I concur. Just tried in my usual browser Chrome and it auto plays, also tried in IE and works fine, FireFox does as you wrote hangs and requires the 2 clicks on play/pause, also tested in safari and this is worse than FireFox here is a screenshot will fire off an email to support now :)

Jeremy Germenis had a reply from support here is a snippet from the email " We're not able to duplicate any of these issues using Firefox or Safari on our end. Our only conclusion is that you have extensions installed on those browsers that are interfering with the videos on our app. You may want to try disabling your extensions and giving it a shot that way. We hope that helps!"

1 Answer

Jeremy Germenis
Jeremy Germenis
29,854 Points

Adam, thanks for contacting support and your response.

I have disabled all extensions and plugins and the problem still persists. I believe this started when I updated to the latest version of firefox last week. I have just been working around the issue.

All I can suggest is you contact support and let them know, maybe another user having this issue will prompt a more thorough check on this. In the meantime I would recommend Google Chrome, a lot speedier than FireFox too :)