Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

General Discussion

Videos loading slow

My videos have loaded slow ever since I signed up here. I have tried restarting both Chrome and my computer with no luck.

Anyone else having this issue?

11 Answers

Hey Justin! If you email our support team at help@teamtreehouse.com they'll be able to recommend some troubleshooting guidelines that should help. :)

James Barnett
James Barnett
39,199 Points

@Justin -

You can try changing your setting in Treehouse to use Flash-based video instead of HTML5

If that doesn't work here are few things to try:

  • Using Incognito mode
  • Using a different browser
  • Using a different PC

It's possible that an extension is causing a conflict. Trying the above steps can help narrow down what the issue is.

If you still need help you then you should email the support team as @faye suggested

I load videos fine in Chrome on both my home and work PCs. Since I am logged in to Chrome it should have the same plugins I believe.

Leads me to believe it is something running on my mac.

James Barnett
James Barnett
39,199 Points

@Justin - On your mac try using Firefox to view the videos and let us know in this thread how you get on.

Yeah that is exactly what I'll be trying next during lunch :P

I tried loading them in different browsers, and just now reset both my wireless router and modem (speed test fine). I didn't think it was the internet since I had the same problem when trying on my work internet connection.

I didn't write anything here because the videos seemed to load fairly well for a few days. Now they are back to pausing all the time :[.

Other Vimeo and YouTube videos seem to load fine...

I just connected to my phones hotspot and the videos loaded fine. Not sure how my router/modem can be the issue when other Vimeo videos load fine and I just rebooted both...

Amardeep Thadisetty
Amardeep Thadisetty
1,347 Points

I too have this issue, the entire website takes too much of time to load..other pages are loading fine. tried in chrome and IE.CLEARED COOKIES,tried in incognito mode..may be the site is loaded with heavy graphics or some thing....

there is no perfect solution,but i have got 1 one trick.Pause the video for 2-3 minutes and then play it,as the long videos are playing slow not the short ones.

Pushkar Kadam
Pushkar Kadam
3,823 Points

I too am facing the same problems with loading of the videos. I checked my internet connections, they are all fine. I even opened it in incognito mode. Still the video is taking a long time to load. Now, this may sound silly, but, on weekdays, when I am using this website, I face the same problem, but I wait for 2 to 3 minutes for the video to load and then start the video. the video works fine after that but on Saturdays, even after waiting for half an hour, the video is not loading. It's just been two weeks since I started using team treehouse, and I have faced same problems on Saturdays. Isn't there a permanent solution for this?

srikanth chavvakula
srikanth chavvakula
6,178 Points

I am facing this issue when viewing videos on Mac, more so when using Safari. Even on Firefox, the videos keep pausing every few seconds. Very frustrating ! Other video sites seem to be just fine. Not sure whats causing this.