Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community!

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial


Wordpress error

i m getting this error whenever i try to install a new theme

Fatal error: Maximum execution time of 30 seconds exceeded in C:\xampp\htdocs\dashboard\wpp\wp-includes\class-wp-http-curl.php on line 332


1 Answer

Austin Whipple
Austin Whipple
29,725 Points

Probably a configuration issue with XAMPP. Try editing the max_execution_time parameter in C:\xampp\php\php.ini

Perhaps increase to 60 or 90 seconds?

It worked Thankyou very much :)