Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

Development Tools Database Foundations Reading Data from Databases with SQL Retrieving a Result Set

Charles Drake
Charles Drake
423 Points

After entering a command to create a new table, it doesnt show under the schema, but is valid. Any help?

I am using the MYSQL Workbench 6.2 CE.

After selecting the specific schema(becomes bold), and entering the command to create a table, the command appears in the output box with a green check, but doesnt appear under the schema I selected or for that matter any of the schemas. Not sure what is going on, I follow the exact steps as seen in the videos.

2 Answers

The schemas don't automatically refresh. Right click in the side bar where your list of schemas etc are and choose the refresh option. You should then see any changes you've made. You may have to expand the tables triangle after refreshing to see the list of tables. Alternatively there's also a little refresh icon right above the list of schemas.

Charles Drake
Charles Drake
423 Points

Oh, thats good to know. Thanks so much.