Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial


Alexander Nortung
Alexander Nortung
6,930 Points

Apache local inviroment, ports blocked

Hi, i tried installing xampp for windows because i wanted to work locally with php apparrently there is a problem, it says that port 80 is blocked. wheni am looking into netstat i see that System with PID 4 is using this port and i don't understand why

i tried googling this but without luck hope someone can help :)

19:54:56 [Apache] Problem detected! 19:54:56 [Apache] Port 80 in use by "Unable to open process" with PID 4! 19:54:56 [Apache] Apache WILL NOT start without the configured ports free! 19:54:56 [Apache] You need to uninstall/disable/reconfigure the blocking application 19:54:56 [Apache] or reconfigure Apache and the Control Panel to listen on a different port

2 Answers

Hi, you can try to stop the IIS (Internet Information Services).

To stop the service, open a cmd as admin and type this command:

net stop WAS

If that does not work, change xampp settings to use a different port, like 8080.

Alexander Nortung
Alexander Nortung
6,930 Points

thank you it worked :), but i would like to understand why port 80 was occupied by system.

That is great! The IIS it's a web server (like xampp) from microsoft that use port 80 by default. It's part of Windows, I think that is why was occupied by system.