Ruby Build a Todo List Application with Rails 4 Build a Todo List Application with Rails 4 Generate a Rails Application

Daniel Brown
Daniel Brown
12,592 Points

Can anyone tell me what version of ruby i should be running for: Build a Todo list Application with Rails 4 please?

Can anyone tell me what version of ruby i should be running for: Build a Todo list Application with Rails 4 please?

2 Answers

Maciej Czuchnowski
Maciej Czuchnowski
36,426 Points

I started with 2.1.4 and then upgraded to 2.2 and I can't remember having any issues.

Colin Bell
Colin Bell
29,668 Points

From the 4.0 release notes (The build a Todo List course uses Rails 4.0.1):

Ruby 2.0 preferred; 1.9.3+ required

So as long as you're running 1.9.3 or later, you should be fine.