Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

iOS Object-Oriented Swift Class Inheritance Creating a Subclass

Code not compiling in editor, but works perfectly in Xcode?

My code runs as follows:

class Vehicle { var numberOfDoors: Int var numberOfWheels: Int

init(withDoors doors: Int, andWheels wheels: Int) {
    self.numberOfDoors = doors
    self.numberOfWheels = wheels
}

}

class Car: Vehicle {

let numberOfSeats: Int = 4

}

let someCar = Car(withDoors: 4, andWheels: 4)

This runs fine in Xcode, but won't compile in the editor. Please help.

Thanks,

Benjamin Letham.

objects.swift
class Vehicle {
  var numberOfDoors: Int
  var numberOfWheels: Int

  init(withDoors doors: Int, andWheels wheels: Int) {
      self.numberOfDoors = doors
      self.numberOfWheels = wheels
  }
}

// Enter your code 

class Vehicle {
    var numberOfDoors: Int
    var numberOfWheels: Int

    init(withDoors doors: Int, andWheels wheels: Int) {
        self.numberOfDoors = doors
        self.numberOfWheels = wheels
    }
}

class Car: Vehicle {

    let numberOfSeats: Int = 4

}

let someCar = Car(withDoors: 4, andWheels: 4)

1 Answer

Andrew Boryk
Andrew Boryk
15,916 Points

Hi Benjamin!

So, I don't if this was a copy paste error, but you have the Vehicle class created twice, and then you have you Car implementation. I took your code and pasted it into the challenge, without the extra Vehicle, and it worked.

Are you still having this problem?