Welcome to the Treehouse Community

The Treehouse Community is a meeting place for developers, designers, and programmers of all backgrounds and skill levels to get support. Collaborate here on code errors or bugs that you need feedback on, or asking for an extra set of eyes on your latest project. Join thousands of Treehouse students and alumni in the community today. (Note: Only Treehouse students can comment or ask questions, but non-students are welcome to browse our conversations.)

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and a supportive community. Start your free trial today.

PHP Building Websites with PHP Contact Form & Sending Email Installing SwiftMailer

Josh Foster
Josh Foster
8,896 Points

Composer never lets me load the latest version of anything

Every time I use composer as directed in the videos, it says "killed" after I accept the latest version found and proceed to download, and returns to the command prompt. I have found the only fix is to request (sometimes by guessing) an earlier version of the package. In most instances I pick the version Hampton is using in the video which is a slightly earlier version. Why won't composer ever load the latest version if the whole purpose is to know and install the latest version? It must be a problem on this end, but what?