Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community!

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial


Error downloading RailsInstaller on my Mac

I am having trouble installing the railsinstaller on my mac, I finish downloading the kit and when I get to the installing process I get this error at the beginning:

"There has been an error. Error changing group of / opt/rix to rvm The application will exit now." Then you only have ok to click on Can someone tell me what should I do to avoid this error, I can't complete the installation of railsinstaller?

Thank you

10 Answers

James Barnett
James Barnett
39,199 Points

It's a permissions error. The easiest way to fix it is to run Repair Disk Permissions on your hard drive.

  1. Open Disk Utility
  2. Choose Macintosh HD
  3. Click Repair Disk Permissions
  4. Restart your Mac
James Barnett
James Barnett
39,199 Points

Jamie - Thanks for letting us know about needing a restart. I've add that step to the instructions in my original post.

Thanks James, I will try that.

Hi Guys,

Unfortunately, I am getting the same error, but the fix didn't work. Any other ideas?

Scratch that last post. Just needed a restart after the disk repair!

Amber Aultman
Amber Aultman
3,360 Points

Worked for me. Thanks for this fix!

Everyone, thank you very much for this post.

thanks James Barnett

Austin Klenk
Austin Klenk
4,399 Points

Fantastic James Barnett, that worked!