Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

WordPress How to Make a Website with WordPress Installing WordPress The Famous 5-Minute WordPress Install

filezila wont connect

I already tried a lot of times, but after a fill the information and hit quickconnect it does not connects... this shows up...

Error: Received TLS alert from the server: Handshake failed (40) Error: Could not connect to server

I also tried in site manager.. please help...

Tanner Legassee
Tanner Legassee
Courses Plus Student 8,926 Points

I feel like there's a lack of information. Make sure that not only are your username and password are correct, but that the server's IP and port are also correct. I feel like the port number would be your stumbling block.

Thanks, I double checked my password and even tried with both port 21 and 22 and still the same...

5 Answers

Chris Shaw
Chris Shaw
26,676 Points

Hi Jose,

Make sure you're connecting to port 21 as a TLS request requires an SSL certificate to be installed for the FTP service which it isn't for your server, the different is port 21 runs on a standard socket whereas port 22 which is what I assume you're attempting to connect to runs through an encrypted connection.

Hope that helps.

Hi! thanks for the answer, unfortunately I just tried with port 21 and 22, still the same...

Jonathan Grieve
MOD
Jonathan Grieve
Treehouse Moderator 91,252 Points

Which version of Filezilla are you running? I recently had problems connecting to some of my (non wordpress) sites after an upgrade to version 10. Once I'd downgraded it was fine again. :-)

I was using the last one for pc (since i'm still on OSX 10.6 the mac version won't work, so I downloaded the PC version which I use in Windows 7 in Parallels) and I'm using wordpress. Still doesn't work. Which version you suggest? do you have a link please?

I had the same issue trying to connect to my Godaddy server for my wordpress sites a month or so ago.

After calling Godaddy, they recommended version 3.9.0.6.

A quick Google Search "filezilla mac 3.9.0.6" bring multiple results!

Good luck!

Hey! Thanks for the reply, unfortunately I'm still ond 10.6 OSX and the 3.9.0.6 is only supported on 10.7 or higher...

Jose,

I recommend upgrading to 10.7 or higher.

My lady upgraded and there really isn't much difference.

Good luck!