Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community! While you're at it, check out some resources Treehouse students have shared here.

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

Ruby Build a Simple Ruby on Rails Application Getting Started with Rails Installing Rails (Mac)

I cant seem to install the correct version of Ruby and Rails?

i have been trying to figure out how to install ruby and rails now for around four days, for some reason no matter what i do, i cannot seem to get it to working correctly. I managed to get a later versions installed but when i started to get stuck in to the "Build a Simple Ruby on Rails Application" i got about a 3rd of the way through and started running in to problems due to the version of Ruby on rails i was using. I am now back to "Installing a Ruby Development Environment" and i am currently at "Installing Ruby on Mac" and the part of the tutorials where it all starts to go wrong is when i enter the following: "rbenv install 2.0.0-p353" i get the following errors:

Daniels-iMac:~ rubycreative$ rbenv install 2.0.0-p353 Downloading yaml-0.1.6.tar.gz... -> http://dqw8nmjcqpjn7.cloudfront.net/7da6971b4bd08a986dd2a61353bc422362bd0edcc67d7ebaac68c95f74182749 Installing yaml-0.1.6...

BUILD FAILED (OS X 10.10.1 using ruby-build 20150226-3-g0901e41)

Inspect or clean up the working tree at /var/folders/dk/d5tcfyvd2fg92k6p4p_1hj1m0000gp/T/ruby-build.20150301182619.9330 Results logged to /var/folders/dk/d5tcfyvd2fg92k6p4p_1hj1m0000gp/T/ruby-build.20150301182619.9330.log

Last 10 log lines: checking for mawk... no checking for nawk... no checking for awk... awk checking whether make sets $(MAKE)... yes checking for gcc... clang checking whether the C compiler works... no configure: error: in /var/folders/dk/d5tcfyvd2fg92k6p4p_1hj1m0000gp/T/ruby-build.20150301182619.9330/yaml-0.1.6': configure: error: C compiler cannot create executables Seeconfig.log' for more details make: *** No targets specified and no makefile found. Stop. Daniels-iMac:~ rubycreative$

1 Answer

i have managed to fix this now, in the end i tried upgrading my osx yosemite, and then when i followed the instructions of the tutorial it worked completely fine, so i guess it was something to do with the set up of my operating system.