Welcome to the Treehouse Community

Want to collaborate on code errors? Have bugs you need feedback on? Looking for an extra set of eyes on your latest project? Get support with fellow developers, designers, and programmers of all backgrounds and skill levels here with the Treehouse Community!

Looking to learn something new?

Treehouse offers a seven day free trial for new students. Get access to thousands of hours of content and join thousands of Treehouse students and alumni in the community today.

Start your free trial

Java Java Objects (Retired) Meet Objects Welcome Back

I can't type "|" in the workspace console

Hi, I can't type "|" (a bar, like in ||) in the console.

I use a Windows PC and on my laptop, I access "|" by doing Alt Gr+6. But in the console, I can't type any of the symbols accessible by Alt Gr, like @ or [

... Anybody got a solution ?

Cecilie Johnsen
Cecilie Johnsen
1,694 Points

I had the same problem on my QWERTY Norwegian keyboard. But when I left click + paste it works, I just couldn't command + v.

11 Answers

OK! I thought about this solution, but I wanted to know if other people experienced this issue. Maybe it's due to my AZERTY keyboard...

Mat Morris
Mat Morris
10,292 Points

I'm sorry! I use a QWERTY keyboard :) I hope someone else that uses an AZERTY keyboard will answer this for you!

Thank you anyway! :-)

Mat Morris
Mat Morris
10,292 Points

Hmmm.... try typing the pipe into a notepad app or simply copying it from here | and pasting it into your workspace.

Craig Dennis
STAFF
Craig Dennis
Treehouse Teacher

I'm going to notify our dev team and see if we can get it working. Does copying a pipe | work ?

Désolé a propos de ça

Merci beaucoup ! I can't copy a pipe in the console, no... There's no problem in the text editor, it's just the console.

Rafael Valera
Rafael Valera
8,401 Points

Same problem here with an Belgian AZERTY, slightly different in symbols position from french AZERTY

Emil Villefrance
Emil Villefrance
528 Points

Got the same problem on a danish QWERTY keyboard. Can't copy the pipe in either.

Mat Morris
Mat Morris
10,292 Points

The term is 'pipe'.

Usually the pipe is located as the Shift + backslash which is right above your 'enter' or 'return' key.

Unless you have a different keyboard, this should work.

Hi, Mat, thank you for your answer, I use a french AZERTY keyboard, this is why I should type Alt Gr + 6 to access the pipe.

The thing is, I can't type a pipe in the workspace console. It just does not work.

Hi,

I had the same Problem as well, i could not type or paste the Vertical Bar | into the Workspaces Console. So i have tried a few ways and finally i used the "Computer Keyboard / Virtual Keyboard" and i changed the Keyboard language to English (United States) in the language Settings. And now i can type the Vertical Bar | by using my normal Keyboard(that did not work before) and by using the Virtual Keyboard(which did not work before as well). So everything is working "fine", it is just a litte annoying to switch between the Languages.(Because the Keyboard layout changes completely)

Hope this might help someone.

Jimmy-Cannon Nwadinkpa
Jimmy-Cannon Nwadinkpa
800 Points

Has the problem been fixed? Because i have the same problem and cant paste anythin into the console.

it could be that one of the keys on your keyboard is broken

I have the same problem, as I have an european keyboard layout. Hope they'll fix this issue soon as it seems that lots of people are having trouble with typing the pipe, and even other symbols usually attained with an alt+ combination (on mac)

I changed my language (Windows 8) to English (USA), changed keyboard to INTL and it works!!

This issue still exists. I can't type @ in the console